New answers tagged

1

public:// is the sites public file system path. You can change it by navigation to admin/config/media/file-system. There you can set the public file system path, the default path is sites/default/files.


0

Have you seen this? https://softescu.com/blog/knowledge-centre/how-migrate-paragraphs-paragraphs-drupal-7-drupal-8 I found it very helpful for migrating my own nodes with paragraphs 7 to 8.


0

There was a fault with my migration yaml. The destination field in Drupal 8 was field_media_audio but as you can see in the question I had it trying to save to field_audio_fileinfo which was the Drupal 7 source. Silly me. Once I realised and corrected the destination it all worked and now media is created and referenced in the one pass of my migration ...


0

When I have done a similar type of migration at that time I did the following steps: First I created media type Audio in Drupal 8 and it's fields. Then I exported all audio file details and FID from D7 and created csv file. Written migration script to import audio into media. Example: source: plugin: csv path: 'csv file path' header_row_count: 1 ...


0

If we want to migrate field collection to paragraphs first you should create paragraph types and it's fields manually. There is no automation available yet to create paragraph types. After that you can write migration script in .yml format to migrate content. Reference(Migrating data from a SQL source): https://www.mtech-llc.com/blog/ada-hernandez/...


1

Don't use the default_bundle at all, instead set the bundle type like other field values in the process section: process: temp_bundle_type: plugin: static_map source: field_list_item_type map: card: card header: header default_value: card type: '@temp_bundle_type'


0

For me this solve the problem: # Only attempt to stub real (non-zero) parents. parent_id: - plugin: skip_on_empty method: process source: parent - plugin: migration_lookup migration: d7_taxonomy_term // this migration parent: plugin: default_value default_value: 0 source: '@parent_id' Source: https://...


0

if migration sounds too hard ... install and config https://www.drupal.org/project/default_content_deploy then "drush default-content-deploy:entity-list" to see a list then: "drush default-content-deploy:export taxonomy_term" "drush default-content-deploy:export node" "drush default-content-deploy:exportcomment" copy the exported files to your next ...


0

We found the problem. The site was using HTTPS on the production server and HTTP on the test server, and we had set php_flag session.cookie_secure On in our Apache config. HTTPS wasn't in use, so no cookies were sent, so no logins would work properly. Setting this to Off worked wonders. Thanks for pointing me in the right direction, folks!


0

You can indeed edit the exported config and then re-import it to make the title field mandatory. Always be careful when editing config directly. The config files generally follow the naming convention core.base_field_override.<entity_type>.<bundle>.title.yml. There should be a required key which is set to false. Simply change false to true, ...


0

The answer is: the logic is not flowed, it is correct. when you write your own custom migration module you can establish dependencies to other migrations that you have done via code or done via UI using migrate_ui or d2d_migrate_ui modules. here is custom migration code that depends on a class generated by d2d_migrade_ui. this code worked for me: $this->...


0

Although it is more elegant to use a sub_process as @dibs proposed, you can also use a get process plugin field_name/value: - plugin: get source: field_name/0/value field_name/format: - plugin: default_value default_value: basic_html


2

Have you tried removing the quotes? field_reference: - plugin: sub_process source: field_reference process: value: value format: plugin: default_value default_value: basic_html


Top 50 recent answers are included