I am using Drupal 7.25 (I need to update to 7.26) and organic groups 7.x-2.4. I currently have public and private groups working. I have two users (admin and a normal user). I have a menu tab that opens the og list (/og-list) view which lists all groups (public and private).

When logged in as a normal user if I click on a public group it shows a subscribe to group link. That's great. However, if I click on a private group it gives me the Access denied page without a subscribe link.

I would like to have any normal user be able to click a private group and have it display a link to subscribe. Any help would be greatly appreciated!

1 Answer 1


You have a couple of options.

Not sure how you have your group node page setup but what I have done is use a node view panel. In that panel I added the Field: Group (group_group) in a region then set the formatter to "OG subscribe link". That will display the "Subscribe to group" link when a user clicks on the group they are not a member of. Since you are getting access denied I'm guessing your group node page is not setup that way.

Another option is to modify the og-list view and add the field "Content: Group". Then change its Formatter to "OG subscribe link". That will create a new column in the view that will display a link called "Subscribe to group" for groups you are not a member of and "Unsubscribe to group" for groups you are a member of.

  • I have the Field: Group(group_group) in my panel and the "subscribe to group" link shows up when a normal user views a public group. However it is still missing when they click on a private group. I also tried option 2 with the same outcome. The outcome still shows the Access denied page and a Navigation panel
    – mkmitchell
    Jan 28, 2014 at 14:31
  • On a second note. On my show all groups page I have two fields. Content: Title and Field:Group(Subscribe). This shows the group (public and private) as well as the ability to subscribe to it.
    – mkmitchell
    Jan 28, 2014 at 14:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.