2

I have been trying to install the search_api_solr module. I installed tomcat and Solr according to the instructions on the module's project site and the INSTALL instruction in the module. However, I am stuck.

According to the INSTALL.txt instructions:

NOTE: The Solr 4.3+ example application is currently not completely supported with the configuration files included in this module, due to a slight change in the directory structure. To fix this, simply copy, move or symlink the contrib/ directory from the top level of the extracted Solr package one level down to example/.

(For other directory structures: the contrib/ directory has to be in the directory two levels up from the one which includes the conf/ directory. For help, just start the Solr server and check the log files for WARN messages – they should state in which place Solr expects the directory to be.)

I checked an sure enough Solr is reporting the following warnings:

00:15:45 WARN SolrResourceLoader Can't find (or read) directory to add to classloader: ../../../contrib/extraction/lib (resolved as: /usr/local/tomcat/solr/drupal/../../../contrib/extraction/lib).

00:15:45 WARN SolrResourceLoader Can't find (or read) directory to add to classloader: ../../../contrib/clustering/lib/ (resolved as: /usr/local/tomcat/solr/drupal/../../../contrib/clustering/lib).

The question is how to resolve this? I am using SolrL ver 4.6.1

  • Doesn't directly answer the question, but have you tried the Apache Solr Search module? I have that running on 4.6.1 on several servers with no problems – Clive Feb 25 '14 at 1:13
1

I was having the same issue.

I ended up copying the contrib folder into: /usr/local/tomcat So I had: /usr/local/tomcat/contrib/ and: /usr/local/tomcat/solr/drupal/

That error about contrib/extract/lib went away, but now I'm getting: "Failed to load file /usr/local/tomcat/solr/drupal/solrconfig.xml"

As seen on the logging screen: http://screencast.com/t/MqtSNpqUljI

UPDATE: I went to the admin section on Solr and tried to add the core called drupal. So it tried to process the solrconfig.xml and found an error: http://screencast.com/t/EEmU4P9M I had the useCompoundFile twice. I fixed it and added the core. After that, it was working fine. I hope this helps out someone. I installed solr on centos by following the lullabot guide: http://www.lullabot.com/blog/article/installing-solr-use-drupal

0

I would not use a tomcat install but the jetty based example included with Solr. You can find it in the solr/example directory. Try running the start.jar with "java -jar start.jar", does it work?

https://cwiki.apache.org/confluence/display/solr/Running+Solr+on+Jetty "Solr comes with an example schema and scripts for running on Jetty, along with a working installation, in the /example directory. It is stripped of all unnecessary features and its config has had some minor tuning so it's optimized for Solr. It is recommended that you use the provided Jetty server for optimal performance. For more information about the Jetty example installation, see the Solr Tutorial and the basic installation instructions"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.