1

I installed the module Views Slideshow 7.x 3.1, including the dependent modules as well as the jquery.cycle.all.js (version 3.03) in sites/all/libraries/jquery.cycle.

I am able to create a slideshow with a numeric pager showing 1 2 3 for the 3 slides I have added.

However, the pager numbers aren't linked and the previous and next buttons look like links but nothing happens when I click them.

Have searched for a solution but found nothing.

Also, the slideshow doesn't cycle, just stays on the 1st slide.

  • Use Chrome DevTools, Firebug or any other debug tool that has the browser that you usually use, to see if there are Javascript errors. – gerzenstl Feb 25 '14 at 21:15
1

Would it be possible to share the link?

It is also possible that there is a jquery conflict (ran into this issue a while ago). In my case it was superfish + flexslider, both with their own jquery source that were not interchangeable. This lead either the slider not working, or the menu not working.

I solved it by using jQuery.noConflict(); https://api.jquery.com/jQuery.noConflict/

  • Hi, thanks for responding. Don't want the link published for too long since the slideshow isn't working but it's here: internews.org/myanmar-media-slideshow. I will look into the jquery.noconflict(). – Patricia Feb 25 '14 at 22:15
  • Also, not clear from the documentation I've read what files should be in sites/all/libraries/jquery.cycle. Is it just jquery.cycle.all.js or should that be renamed jquery.cycle.all.min.js? And should cycle.jquery.json be there as well? Have tried various combinations with no luck. – Patricia Feb 25 '14 at 22:28
  • @Patricia I just created a views slideshow on my local test site with no issue. On a side note, firebug shows that "openlayers.org/api/2.12/OpenLayers.js" is not being loaded correctly. Make sure it is https:// or just // I would suggest that you look into another slider module (there are a lot) such as Flexslider, as there are unsolved issues similar to yours in the Drupal issue area. – rawrzors Feb 25 '14 at 22:59
  • Thanks so much for your help. I will check the openlayers.js and look into other modules if I can't get it to work. – Patricia Feb 25 '14 at 23:17
0

Views Slideshow ver. 7.x-3.1 works as advertised.

However, to get any action, you need to enable not only Views Slideshow, but also something to cycle the slides (e.g. the Views Slideshow: Cycle sub-module). From your description of the symptoms, it sounds as if you've left the last step out.

Here is a link to a quite detailed tutorial about how to set the whole thing up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.