0

I've got a problem with Clean URLs. I had a look around and my problem doesn't look like any thing else on this site or anywhere on the internet.

I have a .htaccess file. It's there and it's working. I know because I've set it to remove www. and it is.

I go to Configuration->Search and Meta->Clean URLs (some people don't pass the clean URLs test but I do, it doesn't even come up) I have the option to turn on Clean URLS:


enable clean URLS


I tick the box and click Save configuration. But this happens:


Bloody doesn't work


NO! I ticked you!

So if I go to a clean URL (/contact) it works. But in the menu it comes up as (/?q=contact).

I thought I'd hack the database and turn it on.

But it was on the whole time... <hold flashlight under chin and look scary>

Does anyone know how to remedy this situation so it stays ticked and comes up clean in the menu?

2

Ok, alright. I'm not going to kill anyone.

Turns out there was a line in my settings.php file:

$GLOBALS['conf']['clean_url'] = 0;

Commented it and everything worked just fine.

That was 2 hours of my life wasted...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.