1

I have a webform which works fine only it is submitted for logged in users.

The problem is that the webform includes a hidden input. When I receive the email (sent by the webform) I can see all the values for the inputs, but the hidden input value is missing.

This does not happens if the webform is submitted for a logged in user.

Is this something related to permissions?

thanks

1

Can you give us the token you use for the hidden field? Maybe the token you use only available for logged user. I used hidden fields but with a general token (for example date or ip_adress) and it works fine for non logged users

  • I used the token get[q]. – chefnelone Sep 6 '11 at 14:16
  • you mean %get[q]?right?I used it and it works for me..what version of webform do you use?I have version 3.14 – Mika A. Sep 6 '11 at 14:55
  • thanks Mika, I change the input to 'text' and then I hide it using css. Not the best but I get it working. – chefnelone Sep 7 '11 at 8:38
0

I had a similar issue when I was using the direct input instead try using the token for raw input. That can help solve the issue.

0

I'm way late to the party, but I don't think the problem has anything to do with your user's status. It's a quirk in the Webform module itself. It doesn't store hidden values in the server-side cache.

That issue queue discussion has a fix to $form_state that apparently works. I'm going to give it a whirl.

I think switching from "Secure value" to "Hidden element" (down at the bottom of the field settings) as making it a regular field and hiding it with CSS. But I could be wrong.

protected by kiamlaluno Aug 19 '13 at 18:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.