0

I am using Drupal 7 And the hybridauth module.

In the past - everything worked great, and new & existing users could connect with Facebook and with Twitter.

Now, I have a problem that no one is able to connect with facebook or twitter.

The "closing..." window is stuck for a long time (looks like refreshing itself all the time - like a loop). When I close this "closing.." window, it looks like the user has succeed to login, but I get a message in a repeat many times that says "You have already registered this identity". When this issue is happen - I usually see that the user is finally login - after this long process and many messages (not a clean connect). It's looks like the problem is mainly on the connection to facebook.

enter image description here

Does someone knows what is the problem, and how can I fix it?

dblog errors:

TYPE hybridauth
DATE Friday, March 28, 2014 - 18:16
USER user name
LOCATION http://www.example.com/hybridauth/window/Twitter?destination_error=home
REFERRER http://www.example.com/hybridauth/window/Twitter?destination_error=home
MESSAGE Exception: User profile request failed! Twitter returned an error. in Hybrid_Providers_Twitter->getUserProfile() (line 77 of /home5/mysite/public_html/sites/all/libraries/hybridauth/hybridauth/Hybrid/Providers/Twitter.php).
SEVERITY error

Here is another db log, that looks fine here, but caused a stuck "closing.." window that refresh itself all the time:

TYPE user
DATE Friday, March 28, 2014 - 19:00
USER user name
LOCATION http://www.example.com/hybridauth/window/Facebook?destination_error=home&destination=home
REFERRER http://www.example.com/ MESSAGE Session opened for hybridauth_Facebook_6003111111.
SEVERITY notice

  • Check youe server error log as well as DB log of your site. Put here what are the error occurs in details. – Rupesh Mar 28 '14 at 16:32
  • @Rupesh Thanks for your comment. I updated my question. – EB84 Mar 28 '14 at 17:06
  • Have you changed site url or Twitter apps callback url ? Go here admin/config/people/hybridauth/provider/Twitter and check the settings. – Rupesh Mar 28 '14 at 17:36
  • @Rupesh Didn't change the site URL. Didn't change the callback url on twitter (it's "mysite.com/hybridauth/endpoint?hauth.done=Twitter."). Anyway, the problem is in both facebook & twitter so I think that it's something on my site. What else can cause the problem? – EB84 Mar 28 '14 at 18:25
4

We had the same exact issue using the above configuration.

It turned out that I had a rule enabled to redirect the user to a page upon login.

When I disabled the above rule everything went back to normal

Probably a conflict between modules.

Thanks, Leonidas

  • Jepp, that was exactly my problem as well or more precisely it was after the rule "Redirect after User edit". Now we have to figure out how to avoid that because we need that rule unfortunately there is no rule-condition that suits our needs. Or has someone another Idea how to redirect after User edited his profile? – Yves Sep 14 '14 at 13:48
  • it is not working for me. any idea – Iqbal Feb 21 at 13:38
0

I solved it by letting hybridauth open the authentication in a popup window. When the user inserts his credentials the popup windows gets closed and then the original page gets a refresh.

To set the popup window for Linkedin: admin/config/people/hybridauth/provider/LinkedIn?destination=admin/config/people/hybridauth there you'll find "Authentication window type" and select "New popup window" instead of "current window"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.