3

I (foolishly) tried to enable an installed module whilst on my shared hosting. The site times out, which isn't all together unsurprising. However now I get this error message whenever I try and make any updates to the site (enable any modules, clear cache, run cron etc.)

Any thoughts as to the cause. Here is the error in full.

Fatal error: views_plugin_display::destroy(): The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition "metatag_views_plugin_display_extender_metatags" of the object you are trying to operate on was loaded before unserialize() gets called or provide a __autoload() function to load the class definition in /home/xxxxx/public_html/sites/all/modules/views/plugins/views_plugin_display.inc on line 272

If it makes any difference it was the Metatag module I was trying to enable.

5
  • I would try enabling Devel, then from the admin menu go to Flush all caches -> Class registry Jun 17 '14 at 11:46
  • The flaw in that plan is that enabling the Devel module creates the error.
    – gdhp
    Jun 17 '14 at 12:24
  • good catch :) You could try disabling and re-enabling metatag Jun 17 '14 at 12:30
  • I downloaded the database from phpmyadmin and uploaded it to a backup of the files I had from half a week a go. For some reason this seems to be working fine, because you know... Drupal doesn't have to make sense. I'll see if I get any problems when I reupload to live server.
    – gdhp
    Jun 17 '14 at 13:09
  • But basically whilst this isn't a 'fix' to the problem it does seem to be a 'solution' (touch wood).
    – gdhp
    Jun 17 '14 at 13:09
1

I had this error when running update after disabling Metatag and Metatag: Views. It went away when I re-enabled those two modules.

That also seems to have fixed some other issues I was having with the modules form; it would white screen on me after disabling (certain?) modules, although I could return to the Admin interface.

1

I had this issue when disabling Metatag: Views and everything get back to work smoothly enabling again. The problems seems to be related to this issue: https://www.drupal.org/node/1278534

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.