0

I'm unable to use the Backup & Migrate module because it's telling me the file permissions are not set correctly. i have tried various settings in the command line using chmod. i've removed rwx from users and group but it's still not working. can someone clue me in exactly how they should be set?

the folders used are files/private/backup_migrate/scheduled and then same for manual too.

neither backup option is working. thanks in advance!

  • If my answer was usefull for you do not forget to mark it as the accepted answer it will give me reputation and the com unity will help you again. – SsouLlesS Jun 29 '14 at 15:10
1

Well last time I had the same problem what I did is connect with fillezilla and right-click to the root folder of my site then change permissions to 777 filezilla will go through all your folders and sites and will change all the permissions automatically, it will take some minutes but then all your folders and files will have 777 permissions, try again to use your back-up and migrate, do not forget to clear chaches, after use backup and migrate change the permissions to your settings.php and your private folder in sites/default/private that forlder is where backpup and migrate saves the backups.

Also make sure the the database user you are using with your drupal has all the privileges.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.