0

I keep getting a cache related error.

PDOException: SQLSTATE[HY000]: General error: 1030 Got error -1 from storage engine: TRUNCATE {cache} ; Array ( ) in cache_clear_all() (line 165 of C:\Program Files (x86)\EasyPHP-DevServer-14.1VC9\data\localweb\projects\web2\includes\cache.inc).

The issue is tied to the query file. The fix is to replace TRUNCATE with DELETE FROM in a query.inc file. That's all fine and dandy, and that error is gone. But, now I have a new one: The site is completely broken and thinks that the cache database folder still exists, which prevents me from importing the backup database, even if I drop the whole database. In short: Backups are useless, as this error seems to do some heavy damage. As well, it shuts down the EasyPHP server.

To make things even worse, I was going over the huge site-crashing error report I just got, and it looks like the fix doesn't even work.

In regards with the above, I think it worked, but something else tied in with it is causing more cache errors.

PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'webone.cache_views_data' doesn't exist: DELETE FROM {cache_views_data} ; Array ( ) in cache_clear_all() (line 165 of C:\Program Files (x86)\EasyPHP-DevServer-14.1VC11\data\localweb\projects\webONE\includes\cache.inc).

I applied the fix I first mention to a new website, as a preventative this time. Low and behold, it came back on the first module install.

1

Why are these paths different when you talk about "your project":

path 1: C:\Program Files (x86)\EasyPHP-DevServer-14.1VC9\data\localweb\projects\web2\includes\cache.inc

path 2: C:\Program Files (x86)\EasyPHP-DevServer-14.1VC11\data\localweb\projects\webONE\includes\cache.inc)

This smells like something is horribly misconfigured.

I've made dozens of drupal sites, typically under Linux, but I have used WAMP myself in the past (not EasyPHP-DevServer). This makes me think it's an issue with the EasyPHP-DevServer and not drupal itself.

While you may not be familiar with it ... have you tried like copying your site files and DB to a Drupal 7 Quickstart project VirtualBox virtual machine, or DrupalPro ... another off the shelf VM drupal-in-box ...

  • The paths are so different because I've changed a lot around. I was using V9 because EAsyPHP V11 wouldn't work no matter what. I figured using VC9 was the issue so I tried to figure out how to get VC11 working and succeeded there only to have the same error show up. Also, it seems like Drupal just doesn't like truncating and that is where conflicts come from. – Trevor Jul 5 '14 at 0:07
  • 1
    so seriously try and install drupal on windows either using the Windows Web Installer which is supported by Microsoft, or maybe XAMPP itself. drupal.org/documentation/install/windows Because it seems like your server configuration is simply broken. – tenken Jul 5 '14 at 0:15
  • I believe so. I didn't want to use any other products because I want my websites to be as authentic as possible while avoiding legal issues from unknowingly using closed-source software. But I've realized that my plan is in vain and that mostly anything to do with Drupal is open source. Right now this book has me installing Aptana and git. I'm probably going to submit to XAMPP. – Trevor Jul 5 '14 at 0:29
  • Another +1 for xampp. That's what I use on windows. – mikeytown2 Jul 5 '14 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.