I was successful at this once and now I forgot how I did it. I'm copying a site's files from my local computer to a host GoDaddy. What I'm doing is installing D7 at the host's control panel, updating the site to D7.29 then copying files from my local D7.29 install to the web and then importing the database. It worked with no problems once a month ago. Now no luck. The best I can do is get the site to appear to be all up and running, all CSS works, can even log in and manage modules if desired, but NO pictures show up. It's as if the folder structure is not known for those files. The reason I believe is that I'm copying from sites/sitename (all the local site specific files) (and then fixing settings.php of course) and then since Drupal on GoDaddy only seems to want to work with /sites/default I'm copying the files to that location, default. Like I said I did it once no problem, now not so... Beautiful site with all CSS and content but no pix. I've even tried this locally and it doesn't work, same problem, wondering what to fix.

Newbie Dave N

2 Answers 2


Adjust the path where your public files are stored - here: admin/config/media/file-system (Configuration -> File system -> Public file system path) - also review the temporary directory.

  • Thanks, I just now figured that out by a warning in Drupal and so I went to that location, now the site works like a charm!!!!!
    – Dave N
    Jul 22, 2014 at 22:34

Welcome to Drupal.

1st lets check the status report:

  • Log in as administrator
  • Append admin/reports/status to your base URL

And see if there are any red items.

Usually if you simply copied over folder from your computer to your GoDaddy space, the permissions might not be right.

See what permissions the folder sites/default/files has. The user that your web server is running as needs to be able to read and write to this folder (and its children).

Another potential problem could be that the path to your files directory might be wrong.

Goto admin/config/media/file-system (by appending that to your base URL) and double check that your paths point to sites/default/files and not site/somesite/files.

This might actually be the reason Drupal is not loading your images, since you had it installed in sites/somesites/files on your local, but changed it to sites/default/files on GoDaddy. In your database, that you imported, Drupal is looking for your assets in the folder that you specified when working on your local install -- which would be sites/somesites/files.

In any case, it might save you time if you start your troubleshooting by visiting admin/reports/status first!

Lastly, a PROTIP: Drupal stores its settings in the variables table in your database and you can usually override these from settings.php (but don't go doing this until you have a comfortable understanding of the system).

  • Thanks. I changed the file location as you described above, now it works like a charm!!!
    – Dave N
    Jul 22, 2014 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.