1

I have a content type called poem and a View page that has path like poem/% too. There is a View page for listing the poems called /poems. The poems page will list all the poem titles linked the actual poem (eg: "a href="poem/1">What a world ).

I have a block in the poem view to show all the poems written by the poet. My problem here is when I go to the node by /node/1, I can see the block that list all the poems written by the poet who wrote the node/1 but when I go like /poem/1 I am not seeing the block that list the poems. The node/1 view has bold header of the title but that's missing in my /poem/1 too.

Please help me how to make poem/1 to have the same view as the /node/1.

/poems -> this will list all the poem titles in site, title link would be /poem/1 instead of node/1

/poem/1 -> display poem content + it should display all the titles of the poem written by the author (/poem/1)

poem list view enter image description here

poem viewenter image description here

node view of the same poem enter image description here

poem view setup enter image description here

1
  • It seems to be clear but not for me. :) It's confusing..poem, poem view, poem block. It seems there is something missing in views block. If possible try to make it simple or elaborate. – Krishna Mohan Sep 12 '14 at 14:29
0

but when I go like /poem/1 I am not seeing the block that list the poems. The node/1 view has bold header of the title but that's missing in my /poem/1 too.

In the Blocks Admin UI at admin/structure/blocks be sure the Block for your block view for a poem listing is enabled for the url path = poem/*.

You can also assign blocks to regions easily with the Context module.

4
  • Thanks for your answer but it's not working yet. There is no restriction on the block view. I am going to attach some screenshots. – balan mahadevan Sep 12 '14 at 15:34
  • What I said is not a configuration value in the Views UI. It is in the Blocks UI in admin/structure/blocks – tenken Sep 12 '14 at 16:01
  • It's enabled and the region is secondary. I am not sure how to enable for the speicfic path. I don't have any restrictions in block visibility settings. Please let me know if that's wrong. – balan mahadevan Sep 12 '14 at 16:23
  • The contextual filter setup was wrong - I set to raw and it's working fine now. Thanks for your time. – balan mahadevan Sep 15 '14 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.