I have added a image field with upload widget to my content type. It is shown when I try to add content as administrator, but not with other user types. Any ideas what may be wrong? Probably some permission or something, but I am simply unable to find out which setting this may be. Any help?

Seems like the fields are visible if I disable the "OG Field access" module. But when I enable it again, I cannot see the fields.

  • What's in your JS console?
    – Mołot
    Commented Nov 1, 2014 at 23:32
  • Nothing in my JS console. What I meant with my first post is that I don't see the upload field (browse etc) in my content form, except when I'm logged in as administrator.
    – janlindso
    Commented Nov 2, 2014 at 0:24
  • Some module do form_alter and hide your field?
    – FriOne
    Commented Nov 2, 2014 at 17:23
  • @FriOne How can I find out?
    – janlindso
    Commented Nov 2, 2014 at 22:35

1 Answer 1


If it's a permissions problem you should go to the People tab at the top of your nav bar. Then under People click on "Permissions" and see if you can find the permissions for the image field and give other users permission there.

  • It seems like it might be a permission problem, but I have simply looked through every kind of permission settings I can find, and I'm not able to find the source. Any suggestions? Is there a way I can find out which permission denies this field to be shown?
    – janlindso
    Commented Nov 2, 2014 at 22:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.