0

I installed FlexSlider as suggested on the module's in Drupal7. I try to put a slideshow on my home page with no luck. I tried to create the FlexSlider Example content but it does not create a slideshow, but only lists the images.

The FlexSlider libs are version 2.4.

The website is here: http://projects.busoniu.net/

the images are uploaded in the FLEXSLIDER EXAMPLE SLIDESHOW and I didn't upload any of it in the FLEXSLIDER EXAMPLE IMAGE.

I get an error when I try to edit the content:

Notice: Undefined property: stdClass::$name in flexslider_add() (line 395 of /data/home/buso01/domains/busoniu.net/public_html/projects/sites/all/modules/flexslider/flexslider.module). Notice: Undefined property: stdClass::$name in flexslider_add() (line 398 of /data/home/buso01/domains/busoniu.net/public_html/projects/sites/all/modules/flexslider/flexslider.module).

In console chrome I can see this error:

Uncaught TypeError: undefined is not a functionflexslider.load.js?nk4e6d:41 (anonymous function)jquery.js?v=1.4.4:34 b.extend.eachjquery.js?v=1.4.4:27 b.fn.b.eachjquery.once.js?v=1.2:55 $.fn.onceflexslider.load.js?nk4e6d:34 _flexslider_initflexslider.load.js?nk4e6d:24 Drupal.behaviors.flexslider.attachdrupal.js?nk4e6d:76 (anonymous function)jquery.js?v=1.4.4:33 b.extend.eachdrupal.js?nk4e6d:74 Drupal.attachBehaviorsdrupal.js?nk4e6d:412 (anonymous function)jquery.js?v=1.4.4:30 b.extend.readyjquery.js?v=1.4.4:38 u

2
  • What versions are you using? Which jQuery Update you installed? What jQuery version is required?
    – Mołot
    Mar 1, 2015 at 18:29
  • I have drupal 7 and flexSlider 2.4. I don't know other specifications because I'm only creating the web site, but the host is someone else. sorry.
    – Elod
    Mar 3, 2015 at 7:53

1 Answer 1

1

Put the Flexslider library in sites/all/libraries.

Check Status page for error with flexslider (admin/reports/status).

7
  • I did copy the lib to that location and the status is: `FlexSlider - FlexSlider library installed. version 2.4 '
    – Elod
    Feb 24, 2015 at 8:20
  • From what I see on your page the flexslider js gets not loaded 'sites/all/libraries/flexslider/jquery.flexslider-min.js' missing in the html. Maybe try to use another theme to see if it is theme related. Feb 24, 2015 at 8:37
  • On Bartik 7.34 happens the same. can this be blocked by my online server provider?
    – Elod
    Feb 24, 2015 at 8:39
  • and clear your cache too. Feb 24, 2015 at 8:40
  • Ohh, now works... so do u know if I could be able to use the other theme with FlixSlider, or how to fix this issue with that theme? thank for helping
    – Elod
    Feb 24, 2015 at 8:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.