0

How do I avoid the following error message is shown to normal users?

PDOException: SQLSTATE[HY000] [1040] Too many connections in lock_may_be_available()

1

There are two issues here:

  1. Users are seeing site error messages that they shouldn't
  2. The error message itself

For 1, go to admin/config/development/logging and set Error messages to display to None. Don't worry, this won't affect messages like "incorrect login details" or "page not found, we did a search instead" ... things that the user really needs to know.

As for 2, here are a couple of things to try:

  • Turn off all your custom modules if you have any, re-enable them one by one to see if you can find the cause
  • Do the same with contributed modules
  • Read up on the error message, there are too many things that could be causing it that are non-drupal specific to be useful on this site.
  • 1
    Actually Error messages to display is already set to None. – edi Mar 12 '15 at 4:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.