1

I was going to use mailchimp module to create my newsletter but an error revealed saying that i should install the version 2.0 of librairies, so i delete both modules, started again,that worked just fine .

When i went to settings of mailchimp, this error revealed:

1)Fatal error: Call to undefined function mailchimp_signup_entity_access() in C:\Users\user\Sites\devdesktop\drupal-7.37\sites\all\modules\entity\entity.module on line 657

So , i tried to clear caches ,another error revealed:

2) i-Warning: Invalid argument supplied for foreach() in drupal_schema_field_types() (line 7159 of C:\Users\user\Sites\devdesktop\drupal-7.37\includes\common.inc).

ii-Notice: Undefined variable: field_types in drupal_schema_field_types() (line 7162 of C:\Users\user\Sites\devdesktop\drupal-7.37\includes\common.inc).

iii-Warning: array_keys() expects parameter 1 to be array, null given in drupal_schema_fields_sql() (line 7179 of C:\Users\user\Sites\devdesktop\drupal-7.37\includes\common.inc).

and Recoverable fatal error: Argument 2 passed to SelectQuery::fields() must be of the type array, null given, called in C:\Users\user\Sites\devdesktop\drupal-7.37\includes\entity.inc on line 317 and defined in SelectQuery->fields() (line 1301 of C:\Users\user\Sites\devdesktop\drupal-7.37\includes\database\select.inc).

any help please!

  • 1
    Did you uninstall the modules (this is a second step after disabling it) within Drupal, or did you just delete the folders? – Neograph734 Jul 1 '15 at 10:36
  • And also have you ran update.php? – Neograph734 Jul 1 '15 at 10:39
  • @Neograph734 i tried to uninstall them before delete but the "on" option was grey ,i didn't run update.php but i wrote this drush command "drush cache-clear all" – nourhein chaieb Jul 1 '15 at 11:02
0

If the on option is grey, it means the module is required by another one. Deleting it will cause other modules to break. The correct thing to do would be to disable the depending modules, then disable the main modules and then go to the 'uninstall' tab and uninstall the module.

But for now try running update.php (drush updb) first and see if it helps. If not. Uninstall the modules properly, install the previous versions, disable and uninstall the previous versions and then install new versions again.

This works in most cases.

|improve this answer|||||
0

The fatal error was gone after I enabled the mailchimp_lists module. I would also agree that a dependency to mailchimp_lists would be needed and just in case it could help anybody else or could be considered by maintainers, I went ahead and created a quick patch for that.

Please find attached to this comment a patch against commerce_mailchimp-7.x-1.x at e0a57df, which adds a dependency to the mailchimp_lists module to prevent the fatal error: Call to undefined function mailchimp_lists_load_multiple_by_name. File attached as: commerce_mailchimp-undefined-function-mailchimp_lists_load_multiple_by_name-2075931-2.patch. It is surely a very small patch, but at least it could prevent users from having a bad surprise with a fatal error, when module is already not that intuitive to configure....

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.