0

I like to create a rule that will overwrite my body field after saving new content. This is content from the same node that has been created(field_update) and some content from referenced users form a user reference field(field_userrefer).

I have a CUSTOM TEXT field called "field_update". This is is were content is written.

My actionrule is :

  • set data value "node-body-value" to
  • [node:field-update] this works.

I have to create conditions to get the required fields I want to show in the data selection. This also works very nice because is can see all fields in my data selection auto complete box.

The problem is that when I add these conditions my body field isn't being populated by my custom values.

Any help appreciated.

When i have a set of rules without conditions.

  • Could you add a screenshot of your Rule's config screen? Or/And even better your exported rule? – Stefanos Petrakis Apr 8 '16 at 12:14
0

I have fixed. Seems like conditions is quite the puzzle. I fetched entity by ID with actions to fix it.

conditions: Entity has field: parameter:node, Field:field_userref

actions: Fetch entity by id(id01) :. type: user, id:node:field-userref:uid Fetch entity by id(id02) :. type: profile, id:entity-id01:profile-main:pid wich made all profile2 fields available.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.