3

Setup

I just followed the directions on the drush website for installing drush.

I performed the command php -r "readfile('http://files.drush.org/drush.phar');" > drush

Then attempted the next command php drush core-status which resulted in lots of text basically saying "Permission Denied".

So I went ahead and performed the next direction which makes the scripts executable. chmod +x drush

The Problem

I then attempted php drush core-status again.

Now the console just sits there when I type the command. It displays nothing and never released back to prompt. I had to ctrl+c to free up the console.

The Question

What am I doing wrong here? Are their dependencies on drush that are not listed in the install document? Is their some way to see errors that are not printed to the console?

I was using php 5.4 originally but updated to 5.5 and that did not solve the problem. CentOS 6.7.

  • FWIW I have the same problem in a docker environment using PHP 7 (the official Drupal docker image) – LightGuard May 10 '16 at 20:42
  • Sorry @LightGuard. I don't know what a "docker environment" is. – danielson317 May 10 '16 at 20:44
  • Well, the phar looks like it's broken. When I removed it and just went with compose, everything worked – LightGuard May 10 '16 at 21:03
  • Please tell us the version of Drush and the Drupal version of the site. – cilefen May 11 '16 at 4:21
  • 1
    I think @LightGuard is correct. I just installed composer then used composer to install drush. It worked fine. So it very possible the version installed by the normal readme is wrong. – danielson317 May 11 '16 at 16:02
1

At the time of my comment the phar for drush wasn't working correctly. That very well may be fixed by now, however, I've still found installing drush via composer to be the easiest solution.

0

Verify that your server has the package php5-suhosin enabled. Disable it or add the following to suhosin.ini file (etc/php5/conf.d/suhosin.ini): suhosin.executor.include.whitelist = phar

-1

You should be calling drush on its own, in the root of the Drupal install:

drush core-status
  • First, that is not what the install readme tells me to do. If I "should" be calling drush on it's own the documentation "should" tell me to call drush on it's own. Second. I did try that and It has the exact same behavior. – danielson317 May 11 '16 at 15:55
  • Also drush does not need a drupal install to function. – danielson317 May 11 '16 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.