0

I'm trying to use Panels and Page Manager in Drupal 8. My current versions of each are:

  • Page Manager: 8.x-1.0-alpha23+12-dev
  • Panels: 8.x-3.0-beta4+41-dev

My current problem is having no idea how to actually make a layout (layout_plugin is installed.) I'm seeing this screen:

enter image description here

It doesn't matter what I change "Layout" to, the "Layout Settings" section doesn't change. I'm somewhat familiar with Page Manager in D7, and expected there to be some sort of layout manager in there, allowing me to choose panels/blocks/etc. I know there's a "Block Page"--and this would work for me--but in any of the tutorials, I've heard something about Block Page NOT being for production?

Nearly EVERY video/tutorial I've seen uses some other version of panels/page_manager, and the look/structure has changed. So, I'm not sure if I'm doing this right or not, if it's broke, or if I just have no idea what I'm doing.

Panels, Page Manager and CTools was supposedly synced with their alphas last year, but they look like they've separated and I'm hesitant to use 5 month old versions of modules on a new release like D8 (particulary, CTools.)

0

Go to all recommended versions.

I was using different/more recent dev/alpha/beta versions of certain modules, but when I went to the recommended versions of...

  • panels (8.x-3.0-beta4)
  • page_manager (8.x-1.0-alpha23)
  • layout_plugin (8.x-1.0-alpha22)

... everything seemed to work okay. This was as of 7-6-2016

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.