0

I used SMTP Authentication Support Module to send the email. I also added my authentication. But still got this error:

SMTP -> get_lines(): $data was "" 
SMTP -> get_lines(): $str is "220 email-smtp.amazonaws.com ESMTP SimpleEmailService-1488596457 6vQ6zwf88YaT38JwrmH9 " 
SMTP -> get_lines(): $data is "220 email-smtp.amazonaws.com ESMTP SimpleEmailService-1488596457 6vQ6zwf88YaT38JwrmH9 " 
SMTP -> FROM SERVER:220 email-smtp.amazonaws.com ESMTP SimpleEmailService-1488596457 6vQ6zwf88YaT38JwrmH9 
SMTP -> get_lines(): $data was "" 
SMTP -> get_lines(): $str is "250-email-smtp.amazonaws.com " 
SMTP -> get_lines(): $data is "250-email-smtp.amazonaws.com " 
SMTP -> get_lines(): $data was "250-email-smtp.amazonaws.com " 
SMTP -> get_lines(): $str is "250-8BITMIME " 
SMTP -> get_lines(): $data is "250-email-smtp.amazonaws.com 250-8BITMIME " 
SMTP -> get_lines(): $data was "250-email-smtp.amazonaws.com 250-8BITMIME " 
SMTP -> get_lines(): $str is "250-SIZE 10485760 " 
SMTP -> get_lines(): $data is "250-email-smtp.amazonaws.com 250-8BITMIME 250-SIZE 10485760 " 
SMTP -> get_lines(): $data was "250-email-smtp.amazonaws.com 250-8BITMIME 250-SIZE 10485760 " 
SMTP -> get_lines(): $str is "250-STARTTLS " 
SMTP -> get_lines(): $data is "250-email-smtp.amazonaws.com 250-8BITMIME 250-SIZE 10485760 250-STARTTLS " 
SMTP -> get_lines(): $data was "250-email-smtp.amazonaws.com 250-8BITMIME 250-SIZE 10485760 250-STARTTLS " 
SMTP -> get_lines(): $str is "250-AUTH PLAIN LOGIN " 
SMTP -> get_lines(): $data is "250-email-smtp.amazonaws.com 250-8BITMIME 250-SIZE 10485760 250-STARTTLS 250-AUTH PLAIN LOGIN " 
SMTP -> get_lines(): $data was "250-email-smtp.amazonaws.com 250-8BITMIME 250-SIZE 10485760 250-STARTTLS 250-AUTH PLAIN LOGIN " 
SMTP -> get_lines(): $str is "250 Ok " 
SMTP -> get_lines(): $data is "250-email-smtp.amazonaws.com 250-8BITMIME 250-SIZE 10485760 250-STARTTLS 250-AUTH PLAIN LOGIN 250 Ok " 
SMTP -> FROM SERVER: 250-email-smtp.amazonaws.com 250-8BITMIME 250-SIZE 10485760 250-STARTTLS 250-AUTH PLAIN LOGIN 250 Ok 
SMTP -> get_lines(): $data was "" 
SMTP -> get_lines(): $str is "220 Ready to start TLS " 
SMTP -> get_lines(): $data is "220 Ready to start TLS " 
SMTP -> FROM SERVER:220 Ready to start TLS 
SMTP -> get_lines(): $data was "" 
SMTP -> get_lines(): $str is "250-email-smtp.amazonaws.com " 
SMTP -> get_lines(): $data is "250-email-smtp.amazonaws.com " 
SMTP -> get_lines(): $data was "250-email-smtp.amazonaws.com " 
SMTP -> get_lines(): $str is "250-8BITMIME " 
SMTP -> get_lines(): $data is "250-email-smtp.amazonaws.com 250-8BITMIME " 
SMTP -> get_lines(): $data was "250-email-smtp.amazonaws.com 250-8BITMIME " 
SMTP -> get_lines(): $str is "250-SIZE 10485760 " 
SMTP -> get_lines(): $data is "250-email-smtp.amazonaws.com 250-8BITMIME 250-SIZE 10485760 " 
SMTP -> get_lines(): $data was "250-email-smtp.amazonaws.com 250-8BITMIME 250-SIZE 10485760 " 
SMTP -> get_lines(): $str is "250-STARTTLS " 
SMTP -> get_lines(): $data is "250-email-smtp.amazonaws.com 250-8BITMIME 250-SIZE 10485760 250-STARTTLS " 
SMTP -> get_lines(): $data was "250-email-smtp.amazonaws.com 250-8BITMIME 250-SIZE 10485760 250-STARTTLS " 
SMTP -> get_lines(): $str is "250-AUTH PLAIN LOGIN " 
SMTP -> get_lines(): $data is "250-email-smtp.amazonaws.com 250-8BITMIME 250-SIZE 10485760 250-STARTTLS 250-AUTH PLAIN LOGIN " 
SMTP -> get_lines(): $data was "250-email-smtp.amazonaws.com 250-8BITMIME 250-SIZE 10485760 250-STARTTLS 250-AUTH PLAIN LOGIN " 
SMTP -> get_lines(): $str is "250 Ok " 
SMTP -> get_lines(): $data is "250-email-smtp.amazonaws.com 250-8BITMIME 250-SIZE 10485760 250-STARTTLS 250-AUTH PLAIN LOGIN 250 Ok " 
SMTP -> FROM SERVER: 250-email-smtp.amazonaws.com 250-8BITMIME 250-SIZE 10485760 250-STARTTLS 250-AUTH PLAIN LOGIN 250 Ok 
SMTP -> get_lines(): $data was "" 
SMTP -> get_lines(): $str is "530 Authentication required " 
SMTP -> get_lines(): $data is "530 Authentication required " 
SMTP -> FROM SERVER:530 Authentication required 
SMTP -> ERROR: MAIL not accepted from server: 530 Authentication required 
The following From address failed: sales@test.com

Does anyone know what's going on here? Why did I get "530" error?

0

I figured out. I used a wrong password for Authentication. I create a new ses authentication credentials in AWS and the problem solved.

Thank you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.