0

This seems to be a known issue in drupal, personal commentary redacted.

So I set up a date format, and any non date-format characters get reprinted at the end of the date.

I first had my formatter set up as Y年m月, but read in the issue that I need to escape characters, so:

Format: Y\年m\月

Preview in Date and Time preview area: 2016年08月

Actual output: 2016年08月 年月

Looking in views where the field is being output (to json in case that makes a difference), there is no custom option for the formatter, so I couldn't try recreating the date formatter in views to see if that would work better.

0

I needed to add the escape characters and then go back in and reassign the format to the type. Just changing the format didn't solve the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.