0

Event is: After saving new content

node problem

When I add new blog type content it shows error. I know this error is occurred for

Set a data value
Parameter: Data: [entity-created:field..., Value: [node:url]

1. I know the problem is occurred  Value: [node:url]
2. But I need the url of the created node
3. how can I get this url
1
  • Anyone here to help ?
    – Roni
    Nov 15, 2016 at 20:29

1 Answer 1

0

Make sure when you use [node:url] in any code, it must be in "" so for example

$path = [node:url];

is wrong, it must be

$path = "[node:url]";

As another solution

When you Set a data value you can use Value textarea and php codes to generate the node url.

this is an example where I post a trimmed field_body and the node url to Facebook. If you need to post the node alias to Facebook, you can use

$nid = [node:nid];
$path = drupal_get_path_alias('node/$nid');

to get the alias then print it in the <?php segment.

enter image description here

2
  • Thanks for your reply @Drupalist . The error is encountered in website when I want to add blogs type content there is a title field and it's type is node module element that is not taken more than four words in bangla but english is not problem. I set a value in action element Set a data value Parameter: Data: [entity-created:field-facebook-message, Value: [node:title] how can resolve
    – Roni
    Nov 16, 2016 at 9:42
  • One thing if I disable rule then the field taken bangla words there is no error occurred @Drupalist
    – Roni
    Nov 16, 2016 at 9:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.