1

I set up d8 site with:

composer create-project drupal-composer/drupal-project:8.x-dev my_test_site --stability dev --no-interaction

Then installed the db and drupal with: drush site-install

Fully working D8 (8.3.3) with no errors at all.

I go to curate the composer.json file with some themes and modules to play around with it to get familiar:

composer require drupal/bootstrap

When this command runs, it results in the following error:

Could not find package drupal/bootstrap at any version for your minimum-stability (stable). Check the package spelling or your minimum-stability

Inside my composer.json (after install)

{
    "name": "drupal-composer/drupal-project",
    "description": "Project template for Drupal 8 projects with composer",
    "type": "project",
    "license": "GPL-2.0+",
    "authors": [
        {
            "name": "",
            "role": ""
        }
    ],
    "repositories": [
        {
            "type": "composer",
            "url": "https://packages.drupal.org/8"
        }
    ],
    "require": {
        "composer/installers": "^1.2",
        "cweagans/composer-patches": "^1.6",
        "drupal-composer/drupal-scaffold": "^2.2",
        "drupal/console": "~1.0",
        "drupal/core": "~8.0",
        "drush/drush": "~8.0",
        "webflo/drupal-finder": "^0.3.0",
        "webmozart/path-util": "^2.3"
    },
    "require-dev": {
        "behat/mink": "~1.7",
        "behat/mink-goutte-driver": "~1.2",
        "jcalderonzumba/gastonjs": "~1.0.2",
        "jcalderonzumba/mink-phantomjs-driver": "~0.3.1",
        "mikey179/vfsstream": "~1.2",
        "phpunit/phpunit": ">=4.8.28 <5",
        "symfony/css-selector": "~2.8"
    },
    "conflict": {
        "drupal/drupal": "*"
    },
    "minimum-stability": "dev",
    "prefer-stable": true,
    "config": {
      "sort-packages": true
    },
    "autoload": {
        "classmap": [
            "scripts/composer/ScriptHandler.php"
        ]
    },
    "scripts": {
        "drupal-scaffold": "DrupalComposer\\DrupalScaffold\\Plugin::scaffold",
        "pre-install-cmd": [
            "DrupalProject\\composer\\ScriptHandler::checkComposerVersion"
        ],
        "pre-update-cmd": [
            "DrupalProject\\composer\\ScriptHandler::checkComposerVersion"
        ],
        "post-install-cmd": [
            "DrupalProject\\composer\\ScriptHandler::createRequiredFiles"
        ],
        "post-update-cmd": [
            "DrupalProject\\composer\\ScriptHandler::createRequiredFiles"
        ]
    },
    "extra": {
        "installer-paths": {
            "web/core": ["type:drupal-core"],
            "web/libraries/{$name}": ["type:drupal-library"],
            "web/modules/contrib/{$name}": ["type:drupal-module"],
            "web/profiles/contrib/{$name}": ["type:drupal-profile"],
            "web/themes/contrib/{$name}": ["type:drupal-theme"],
            "drush/contrib/{$name}": ["type:drupal-drush"]
        }
    }
}

I've followed the solutions on Installing Bootstrap theme using Composer , but it seems all the answers are all defaults already in my installation unless i'm missing something?

I've tried several different combinations of versions available for the bootstrap theme and it's the same message every-time. I have also tried to change my overall projects stability with no luck.

I'm not too familiar with composer so I am assuming I am missing something small. Going through the documentation I am literally finding nothing to help solve this issue with composer. I have had no issues installing bootstrap before everything was on packages.drupal.org

Any ideas to why I cannot install bootstrap theme as a dependency or am I approaching this entirely wrong?

3

Sounds like you're in the <project_root>/web folder. You need to be in <project_root> when using the Drupal Project to manage modules.

Just cd .. and run composer require drupal/bootstrap again, it should be fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.