0

Realy need your help. I'm working with quite old Drupal 7 site and for some reason I cannot move the Main Page Content block to any different region. When I drag&drop it to the Header region (on block management page) and then click save, looks like it sucessfully moved, but when I go to the actual page I can see that it still located in the Content region.

Looks like something is preventing Main Page Content block from moving to different region but I don't know exactly what. I've updated Drupal to the latest release - no difference. I've switched to another theme - no luck.

What might be the problem? I'd be very gratefull for any idea.

  • Does you theme changes work? Check the settings.php file whether site to pointing to any versions, check $base_url or any other scripts overriding? – developer Feb 15 '18 at 9:26
  • First off i'd rule out if it is actually just this block or if it's all blocks. Try moving a different block into a new region and see if that actually works too. If not it could be several different things preventing the block form from storing its data. I'd check the error logs if that is the case – Leigh Feb 15 '18 at 13:03
  • Maybe the block has been added programmatically via some custom module? – leymannx Sep 18 at 13:36
1

Something similar happened to me. The problem was that the main content block was configured to show on "all pages except those listed" and the one listed was front. When I removed front, I was able to move the block, or rather my changes showed up on the front page too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.