0

I'm working on a Drupal 7 site in which I'm using Meta tag module for SEO purpose. I have configured the meta-tags global and content settings.

When I try to edit a node for a content type, for example, edit an Article, inside the meta tag section in the page title field, it always displays <em> Edit title </em>, even I have removed all the tokens for this field but it still displays these tokens.

These are the global and content configurations.

screenshot

screenshot

This is how it displays the page title field inside the meta tags section in the content node edit page.

screenshot

I want to remove <em> edit Article </em> and [current-page:pager].

  • You are trying to edit content node edit page, which in fact copies the global page. You should have similar Page title global setting field, remove tags there. – AltaGrade Apr 1 '18 at 16:58
  • Hi @AltaGrade! I have removed it from Global Page title field also, you can see the above placed image for Global settings. – Abdul Rehman Apr 1 '18 at 17:03
  • Maybe you are editing a node that was saved before you changed Meta tag setting. Does the problem persist if you try to create a new node? – AltaGrade Apr 1 '18 at 19:01
  • yup, you are right, it's not displaying for new nodes, is there any way to delete it from all previous nodes? – Abdul Rehman Apr 2 '18 at 5:13
  • Since we found what the problem was, please accept my answer below and I will try to help you further. – AltaGrade Apr 2 '18 at 14:59
1

If you indeed removed tags in global and content settings, then they should not appear when creating new nodes. What you are looking at is probably a node that existed before you changed the meta tag settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.