1

I am using Domain and LDAP modules on Drupal 7, and upon login as a non-admin non-LDAP user, e.g., "author01", I get a blank screen. Upon viewing source on said blank screen, I can see the HTML for the "Welcome to your new Acquia Drupal website!" page—it is just not rendered in the browser (Safari, Chrome, FF).

When logged in as admin, I can switch to "author01" using the "Switch User" block of the Devel module without issue and the Welcome page appears without issue.

The LDAP module is enabled using "mixed mode authentication," Drupal first and LDAP second; LDAP user are able to login without issue, while Drupal-only users get this blank screen upon login. The Domain module is enabled, and but I haven't added any new domains.

I suspect this issue first started after I installed the domain module and "Rebuilt Permissions." Mixed mode authentication was working fine before that.

I've tried various combinations of enabling/disabling and installing/uninstalling the LDAP and Domain modules, clearing cache, rebuilding permissions, and the only time the "author01" user can login is when LDAP authentication is disabled. I've tried enabling error reporting based on Drupal's WSOD page, but the blank pages continue to appear. Apache access and error logs are fine.

Under reports (admin/reports/dblog), I see these log messages (read it bottom up):

ldap_authentication 04/22/2011 - 11:01  Error: users found with uid=author01 under dc=gwu...        
ldap_authentication 04/22/2011 - 11:01  author01 : Success at connecting to devldap     
ldap_authentication 04/22/2011 - 11:01  author01 : Trying server devldap where bind_method = 1      
ldap_authentication 04/22/2011 - 11:01  author01 : Exisitng Drupal User Account not found. ...      
ldap_authentication 04/22/2011 - 11:01  author01 : Drupal User Account found. Continuing on...      
ldap_authentication 04/22/2011 - 11:01  author01 : user_load_by_name(author01)  

The user "author01" definitely exists in the "user" table, has a role ("Content Author"), and the role has permissions.

So I guess I am stumped here, Do you have any idea on what else I can try to troubleshoot and fix this?

  • For what it's worth LDAP for Drupal 7 has 2 releases "dev and unstable", so it's not completely unheard of experience problems like this :) – Alex Weber Apr 24 '11 at 14:17
1

Of course, shortly after I post this, I am able to fix it by deleting and recreating the entry for the ldap server. Hope this helps someone else save lots of time (-:

  • I guess you can select your own answer then :) – Alex Weber Apr 24 '11 at 14:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.