After a Debian update my Drupal 8 installation can not show single nodes and spits the following error.

Error: Class 'DOMDocument' not found in Drupal\Component\Utility\Html::load() (line 286 of core/lib/Drupal/Component/Utility/Html.php).

I have no clue what to do and have installed all required php extensions, following some other issues with the same error.

I already removed all suspicious contrib modules and I am lost now with a broken project.

Any suggestions would be very helpful.
ENV: Drupal 8.5 | PHP 7.2.9

2 Answers 2


That sound like it can't find php Dom extension, to get that try sudo apt-get install php-xml, it should solve your problem


Even after installing PHP-dom and PHP-XML, I was getting the same error. So I did a restart of PHP-fpm and Ngnix. It started working after that

  • 1
    in my case i restart the server
    – Baach
    Oct 27, 2021 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.