0

I'm trying to create a new workflow in Drupal. When I click "Content Types" beneath the "This workflow applies to:" section, it loads an empty modal. I have 6 content types but they fail to show.

There is an existing workflow that has the correct content types set. However, if I uncheck one of them, it won't be available if I try to add it back later.

I made a new, test content type. It will show as an option for workflows but the older, existing options will not.

Does anyone have any ideas as to why the content types won't load inside of the workflow editor?

5
  • Not sure what's gone on there. You could try doing into edit one of the existing content types and clicking save to see if that sorts it. It could be you've updated core and a setting isn't populated somewhere that should be
    – Leigh
    Jan 25, 2019 at 16:08
  • Content types don't really have a "save" button. I can save a change to a field, though. I tried that and it didn't work. I'll try other, similar ideas and will report back. Jan 25, 2019 at 17:29
  • I was referring to the edit screen for the content type .e.g /admin/structure/types/manage/page for the basic page content type
    – Leigh
    Jan 25, 2019 at 17:35
  • Sorry, my mistake... I tried it but it didn't work. They still don't appear. Jan 25, 2019 at 17:36
  • I've tried everything I can think of in the Content Types and they still won't appear. Jan 25, 2019 at 18:20

1 Answer 1

0

It seems each content type can only be assigned to one workflow at a time.

Try removing removing a content type from the other working workflow, save it, and then adding it to the new workflow.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.