0

I'm trying to migrate custom content types with attached fields from Drupal 7 to Drupal 8. Using drush migrate commands I can successfully migrate all content types, but I have problem with fields.

First I run upgrade_d7_field migration, than upgrade_d7_field_instance and last migration is upgrade_d7_node_MY_CONTENT_TYPE_NAME_content.

If I go to Structure -> Content types and then open my custom content type (by pressing Manage fields) I can see all fields attached to it - everything is ok. If I choose Content from main menu and try to create new content for my content type I only see Title field, no more fields are displayed. Same are with migrated content - if I 'm trying to edit it, I see only title.

What I'm missing ? I have migrated data in Drupal 8 fields table - node_field_MY_FIELD_NAME. I am logged in as admin user, so I should have all permissions to view this fields.

0

It sounds like the fields might be disabled on the entity form.

Goto Structure -> YOUR CONTENT TYPE -> Manage form display

Then move the fields you are expecting to see in the form from Disabled (bottom) to Content. You can also control the display order from there.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.