3

I have a situation during the checkout process where the customer is skipping the payment and moved directly to the fulfillment state. I'm using the Commerce PayPal module.

Here's my checkout flow: /admin/commerce/config/checkout-flows/manage/default

My checkout flow config

What's odd is the PayPal buttons display when I'm logged in as Admin, but not when non-admin:

My payment option screen

I haven't found an option that looks relevant on the permissions screen, nor have I found a configuration option anywhere.

The order type is configured to use the correct checkout flow (Default).

3

With Commerce Paypal, I ran into the same issue.

I believe the fix for me was to the move the Payment Information (currently disabled) into the Order Information section. Might also work if you move into Review or Payment section, not sure.

Also, since you're using Paypal, I think you need to disable payment process.

Here is my working setup. Note: I didn't want users to login nor register.

5
  • 1
    Out of curiosity, had you done anything to disable the "Payment information" pane? It should be enabled by default, right? Aug 24 '20 at 15:17
  • 1
    @RyanSzrama correct, that's the default. Because one thinks that PayPal contains the payment information there is a tendency to think that it's not needed and to manually disable it.
    – No Sssweat
    Aug 24 '20 at 15:34
  • 1
    Plus, I'm sure it only happens with experienced Drupal developers who think they're too good 😂.
    – No Sssweat
    Aug 24 '20 at 15:43
  • 2
    Ahh, hah, well - certainly something we can document against! I was just checking w/ jsacksick in Slack about this earlier to make sure there wasn't anything funny going on in the module itself. 🙂 Aug 25 '20 at 3:03
  • It could not be any clearer than that... And moving it to any other pane will show the payment info (in my case showing PayPal twice as an option (radio buttons)). Thanks for this answer, I need to remember to never move it again. Took me 2 days to figure out that this was the issue.
    – MrUpsidown
    Sep 8 '20 at 13:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.