1

I was struggling with high page load time for my node pages when I realized that the problem was due to content pages not being cached (html render cache). The page is rebuilt after every single request. With some hit and trial, I realized that fields that have form elements, in my case, Fivestar widget and also the comment form at the bottom of the page prevent page from getting cached. Either of these fields cause this problem.

When I remove those two fields, page starts to get cached.

Has anyone else dealt with a similar issue? What is the best recommended approach to make sure the page continues to get cached?

2
  • 1
    It's obvious that by adding comments or fivestar the page is less cacheable and you need more server time to build a page. Your question is too broad, though, because it's unclear on which caching level you experience the performance issue and which of those two modules is causing the issue, the core or the contrib one. – 4k4 Feb 9 at 16:22
  • Thanks. I edited my question to make it more specific. I am talking about the render cache for the page. Also - any of those fields cause the issue. Both have to be removed for the page to have render cache enabled. – aroopk Feb 9 at 18:10
0

I realized this was an issue because I was using the Honeypot module. Honeypot disables caching on all pages where there is a form. I updated the setting in the module to exclude node pages and it fixed the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.