3

I have a recurrent problem I can't solve.

when working in localhost I use ckeditor to upload images to the body field. These images are shown correctly.

Then after, I upload the site to the remote host and all those images links are broken.

The problem is that the drupal installation on my localhost is inside a folder in localhost like: http://localhost/mysite.com/

In the remote host all the images links have the mysite.compart of the url which of course is wrong. This is not solved by clearing caches.

Localhost (works fine)

http://localhost/mysite.com/sites/default/files/resize/icon-questions-180x127.png

Remote (with the wrong "mysite.com")

http://mysite.dde.oneserver.com/mysite.com/sites/default/files/resize/icon-questions-180x127.png

With no luck I tried with several configurations at: admin/config/content/ckeditor/edit/Full

UPDATE (trying with Pathologic module) I added these lines in "All base paths for this site" in Pathologic setting at admin/config/content/formats/full_html:

http://localhost/mysite.com/ (this one is where the site was developed)
http://mysite.dde.oneserver.com (this one is where the site lives now)

I ALSO tried adding:

http://mysite.dde.oneserver.com/mysite.com

look the capture: enter image description here

  • What does the actual path in the field look like? Is it /mysite.com/sites/default/files… ? If so, try putting /mysite.com/ in the "All base paths for this site" field. – Garrett Albright Nov 8 '13 at 23:27
3

You might want to try Pathologic module to see if that works for you.

Pathologic is an input filter which can correct paths in links and images in your Drupal content in situations which would otherwise cause them to “break;” for example, if the URL of the site changes, or the content was moved to a different server. Pathologic can also solve the problem of missing images and broken links in your site’s RSS feeds.

| improve this answer | |
  • I have pathologic enabled. I'll try it. – chefnelone Jan 15 '13 at 13:03
  • I can't get it working, could you take a look at my update at the bottom of the question – chefnelone Jan 15 '13 at 14:07
0

May be there was a configuration missing! Have you ever try the following way to resolve the problem? I think it might be a good choice for you (this CKEditor add-on will automatically calculate correct URL for your images: in my projects I leave in not configured and it successfully understands what URL prefix must be used):

http://doksoft.com/soft/ckutils/bundle-install.html

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.