2

I just moved my Drupal 7 site over from one host to another. At first, everything seemed to be working just fine, but I keep getting this strange problem when dealing with modules.

The installation appears to go without a hitch, and it shows up in the modules list. It also shows up under the correct path in /sites/all/modules/$modulename. However, the problem I get is two-fold:

  • Attempting to go to the configuration page for the module does virtually nothing. It just takes me to the related menu for whatever admin category that particular module falls into. (For example, Disqus would take you to Web Services rather than a Disqus configuration panel).

  • Disabling the module doesn't remove it from the configuration menus, either. I've tried running cron, flushing my caches, and even using the registry_rebuild scripts.

This also affects my themes now. I can't seem to get any of my new themes to appear in the directory when I upload them into my /sites/all/themes/ directory. I can remove themes manually, and they disappear at least. But, as you can imagine this is all a very frustrating problem. I think it may possibly be a permissions error, but frankly I really have no idea.

  • Do you have the problem with a module you wrote or a module you didn't write, but you installed on your site? – kiamlaluno Aug 1 '11 at 14:57
  • No, I haven't written any modules. Just all of my modules were working before the transition over to the new server, and now enabling/disabling them really doesn't do anything, aside from showing that they're enabled/disabled. – Sean Tilley Aug 1 '11 at 15:16
1

My first thought was permissions, but I don't think that incorrect file permissions would result in the kind of problems you're seeing.

Have you checked that the server has all the same extensions installed for PHP? If you've still got access to the old server, put a phpinfo() page on both server and compare the extensions that are available to see if any are missing.

  • 1
    Permissions is a good guess. Another good guess is clean URLs. If clean URLs aren't working for whatever reason (webserver config, you've lost the .htaccessfile...) you can get issues like this. Try using drush to turn off clean urls (drush vdel clean_url) and go in again. Come to think of it... make sure you didn't lose the .htaccess file when copying the site. – rfay Aug 2 '11 at 20:21
  • CleanURL's work out of the box, and the .htaccess files is unmodified from the other site. I'll take a look at the PHP extensions, but I'm pretty sure everything is supported on that end. If it's a worst-case scenario, I can try scrapping the current site and starting over, since we haven't launched yet. – Sean Tilley Aug 2 '11 at 22:46
0

This is a really old thread but thought it was worth adding the following.

I had this problem recently on a local dev install (using Acquia Dev Desktop, by the way). Turning off the Memcache module resolved my issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.