4

Better Exposed Filters is not showing the option for Radio buttons and Check boxes. How do I enable it?

Better Exposed Filter working well and good until I enable the Auto Submit option. My Check boxes are gone and shows simply the list. So I uncheck the auto submit, but still i don't get the options to choose.

The filter criteria are set to "Content: Has taxonomy term"; the selection type is "Dropdown."

screenshot

6

This also tripped me up. The settings weren't where I expected them to be and there were a couple of prerequisites. Maybe this is your issue too?

  1. Create a View and expose a filter
  2. Under Advanced > Exposed form > Exposed form style select Better Exposed Filters
  3. Under BEF Settings roll down to the bottom where there are the Exposed Filter settings and select Checkboxes/Radio Buttons from the drop down menu.

Note: You can't select these settings for filters that don't have a limited number of options. (A title won't work, but a term will.) The documentation says:

BEF only operates on fields that have a limited number of options such as Node:Type or Taxonomy:TermID. Open-ended fields, such as Node:Title, do not work with BEF. Entity References do work, however, if you Enable Render Views filters as select list (a checkbox) in the Entity's entityreference field.

I had utilized the entity reference field pattern. You need to edit the field you are referencing in the Content types > [content type] > manage fields > [field name] > edit. field settings. There, at the bottom of the page under Additional Behaviours you will find a checkbox for Render Views filters. That will allow the aforementioned select box (in BEF settings) to properly display the Checkbox/Radio option.

0

It's possible to make checkboxes list for nodes. Here is a good manual for Drupal 6: Filtering A View By A List Of Nodes With Checkboxes. It helped me with D7 also.

For Drupal 7 it requires several code modifications. Unfortunately, there is no possibility to add comments on this blog with code changes for D7.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.