1

I've installed domain access module and all its submodules. I have two domains (both set already) and I would like to assign node to one of these domain only.

I set the proper domain in node edit form, but it really doesn't affect the anonymous user permissions, because ALL users can view this node from all domains.

enter image description here

Devel node access displays on the node page something like below: enter image description here

I checked user permissions as well and everything looks pretty good there.

How do I configure this module to access node only from the right domain?

--- edit ---

after change suggested in one answer it looks like

enter image description here

enter image description here

  • It might be good idea to switch to English before making a screenshot. And by the way you want that restriction to apply for all nodes with domain set? – Mołot Aug 20 '13 at 13:22
  • '' Yes. There is an option to set where the node should be published (while node editing). – deem Aug 20 '13 at 13:27
  • I admit I don't remember details, but I believed that, if set, it should simply work. If you are not messing with it in any way, maybe it's a bug in module? Edit: Just seen the answer below and it looks like you did. – Mołot Aug 20 '13 at 13:39
  • OK, so now problem is with second row. It is supposed to be 0, but it's 1. Try to rebuild permissions and test again. – Mołot Aug 20 '13 at 14:01
  • There is no access after permission rebuild from any domain now. – deem Aug 20 '13 at 14:04
2

In your screenshot above there is a "Send to all Affiliates" checkbox and then checkboxes for each individual domain. If you leave the "Send to all Affiliates" checked it overrides the individual checkboxes.

So, the solution for you is to uncheck the "Send to all Affiliates" checkbox.

  • It doesn't help. I can still (as anonymous) see node from dev.drupal/content/testestestest and test.drupal/content/testestestest – deem Aug 20 '13 at 13:40
  • @daroPL are you sure you have cleared all caches along the line? From Drupal's to bowser's? – Mołot Aug 20 '13 at 13:40
  • @Mołot yes, I've done it. – deem Aug 20 '13 at 13:44
  • @daroPL so please update your screenshots to reflect current state of your configuration and node assess flow. – Mołot Aug 20 '13 at 13:46
  • @Mołot attached. – deem Aug 20 '13 at 13:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.