I have a content type in which I used a date field and for the same i have used this field -> https://drupal.org/project/date

My problem is I want to set the date format as " September 13, 2013 | 3:39 UTC |" , so I overrode the format and made it 'F j, Y \| H:i e' (refering to http://in3.php.net/manual/en/function.date.php)

but it is only showing the year (e.g. 2013| ), not other things.

Can anyone help me with this?


Path: Home » Administration » Configuration » Regional and language Or

Path : admin/config/regional/settings

In the above path there will be tab called 'format' where you can create your own custom format where format string is F j, Y, g:i a e.
Now you can change the date format of the field from the manage displays tab of the admin/structure/types path.
In the respective field you will have settings options where you can set your custom date format

| improve this answer | |
  • but instead of UTC it shows America/Los_angels , any solution for this? – ruby Sep 13 '13 at 10:59
  • 'e' refers to the Timezone identifier Examples: UTC, GMT, Atlantic/Azores as shown in the link in1.php.net/manual/en/function.date.php – harshal Sep 13 '13 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.