0

"The specified file temporary://filelo2Fkx could not be copied, because the destination directory is not properly configured. This may be caused by a problem with file or directory permissions. More information is available in the system log."

ANYWAY what I am getting is everything minus theme and all images but strangely my multi site folders in root drupal sites folder are all working fine.

In the end I solved it by putting the root subfolder in sites along with other multi-sites. No amount of changing permissions or ownership or clean install or dropping and recreating database worked until then...which is very odd because it used to before I took the site down.

2 Answers 2

0

You can try and change the permission of the folder 'sites/all/files' to give it 777 permission in your drupal installation and see if this works.

4
  • Thanks I have already done that but still get same error because now I have no clue what ownership should be on all the folders.
    – cea
    Oct 6, 2013 at 5:25
  • I think giving the owner 777 permission and others only read permissions should work. Did you already try this?
    – Neo
    Oct 6, 2013 at 5:41
  • I have tried 777 root:apache and tried apache:apache and root:root on files folder but still get the error.
    – cea
    Oct 6, 2013 at 6:29
  • weirdly my multi-sites listed in sites folder are all fine.
    – cea
    Oct 6, 2013 at 6:30
0

you have a problem with temporary directory (/tmp is the default).

Read this: https://stackoverflow.com/questions/5040718/file-system-permission-error-while-installing-drupal-modules

M.

4
  • Nothing is working
    – cea
    Oct 7, 2013 at 3:00
  • Ok. Have you opened an assistance/help ticket with your ISP ? M.
    – ZioBudda
    Oct 7, 2013 at 6:29
  • it is an unmanaged VPS
    – cea
    Oct 7, 2013 at 8:00
  • I think what I will try doing is do vanilla install and then just bring sql for those one's not working.
    – cea
    Oct 7, 2013 at 8:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.