1

I have installed the Message module to log activities, and set it up following these instructions.

All steps look good, and message (admin/content/message) is created after I added new content. But, the message's TEXT field is empty.

Also, Message: Render message (Get text) field in related View is also empty, and SHOW NO RESULTS BEHAVIOR is triggered.

I enabled message_example module come with message, same result.

Is there anything wrong with my options?

  • Have you checked if permissions conf is needed? – rreiss Dec 26 '13 at 6:14
  • I am using ADMINISTRATOR, so not the permission. – leetom Dec 26 '13 at 6:44
  • @Rotem I checked Message class, and it turns out that I have a wrong language code, 'cause I set administer language to English other than default language. It works now after I set language back to default. – leetom Dec 26 '13 at 6:46
  • I think you need to give message permission to administrator. – Mahipal Purohit Dec 26 '13 at 7:13
0

This is a rather typical issue in multi-language sites. A variation (not duplicate) of your question is what is described in "Rules - Set language of message notification".

A possible solution (work-around?) is what you wrote in your own comment below your question, i.e.:

I checked Message class, and it turns out that I have a wrong language code, 'cause I set administer language to English other than default language. It works now after I set language back to default.

Another solution is to indicate the language in which the message is to be created.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.