0

I'm sure this is a simple configuration issue, but (I think) I've looked everywhere and I can't see what's wrong...

I have a content type "Sponsor" that is basically just a name (title) and a logo (image field). I created a few sponsors for my tests.

I also have another content type ("City") with two node reference fields, both of which allow to pick an unlimited number of sponsors (nodes). (I use two fields because one should display the sponsors logos, while the other should only display the name of the sponsors.)

On "Manage display" (for the City content type), the first node reference field format is "rendered node", while the second is "Title (no link)".

So when I visit a "City" page, I should see two lists of sponsors (one with logo, the other one without).

It works for me (admin), but for anonymous users, the sponsors simply don't show up. They are published, though, and anonymous users can access the sponsors pages (and see the logo as well as the title). But when they are referenced through the "City" nodes, the sponsors somehow become invisible (not rendered).

What am I missing here?

Weird thing is, I have another page where I use Views to output the list of sponsors for a city: in that View, the sponsors are still invisible (nor anonymous users, not admin), but the list elements (containing each sponsor) are indeed rendered --so anonymous users see empty bullet points and it matches the number of sponsors that should be visible there.

Note: I also use Panels to display the city. But the problem is still there when I disable the node template Panel, so it's not that...

1

Found it!

I'm using Organic Groups on this site, and I didn't realize that you could grant access permission (view/edit) on a field level (contrary to the base Drupal permissions system, which works only with content types). Since it doesn't show up on the "normal" Permissions page, it's easy to miss. (It's in configuration > Organic groups > OG permissions overview).

So it was indeed a simple configuration issue.

  • Thank you so much for posting this. We had already disabled SQL rewrites and couldn't figure out what else to try. – Stacy H Jun 20 '18 at 22:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.