5

Does Drupal 7 use some special libraries for MySQL?
I tried to install the 7.8 version, and the only option for the database I have is "SQLite."

I am running Drupal 6 on the same server, and it works fine. I am using PHP 5.2.8, and MySQL 5.1.38.

Do I need any additional library?

9

You need to have the PDO driver for MySQL installed for Drupal 7. This is indeed different from Drupal 6. Instructions are at http://drupal.org/requirements/pdo. I hope those instructions are sufficient for you.

|improve this answer|||||
  • you're right, I had only the PDO driver for sqlite , thanks – PartySoft Sep 8 '11 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.