0

I want to use a custom 404 page, I also have a theme installed.

This is what I did:

  1. Go to Content, create a Node, I got path: node/28
  2. Go to System->Site Information->Error Pages-> 404 page, I enter node/28

Then I type some pages that are not exists, it doesn't link me to the node/28, instead, it still use the themes' 404 page.

Some hint here?

BTW, I am using Drupal 7 and the theme called MD magnum.

| improve this question | | | | |
  • Did you try clearning cache? If not use drush to do so: drush cc all – CR47 Apr 7 '14 at 16:49
  • does your theme already have an error page template? – jdu Apr 7 '14 at 16:50
  • @CR47 Hi,thanks, I clear the cache, and it works, but not correctly, the themes' 404 page overlap with my node/28. I only want to show my own 404 page, so what should I do to disable the themes' 404 page? – Xinrui Ma Apr 7 '14 at 17:02
  • @jdu Hi,thanks, I clear the cache, and it works, but not correctly, the themes' 404 page overlap with my node/28. I only want to show my own 404 page, so what should I do to disable the themes' 404 page? – Xinrui Ma Apr 7 '14 at 17:03
0

Do what @jdu said and check the theme's template files for an error page template. It will probably have the name page--error.tpl.php and probably be in /sites/all/themes/md_magnum/templates/

After that set your new error page URL in admin/config/site-information to the node you created.

To verify it is set you can check in your database under the variables table for site_404 to be set to that URL.

Make sure after you make these changes you clear cache completely and refresh your page. If you are in Chrome, you may have to clear browser cache as well if you are using the same URL.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.