0

enter image description hereI want to have different filter criteria for one display in my views. I added it and when i hit "Update preview", the data shows up as expected in the bottom area of my views window. But then, when I surf to the url or when I hit the link specified at Path, I get data that appears without that filter applied. I have hit the save button on top, too. What else am I missing?

edit 1 Also, I have realized that my second display also shows the title of my first display but I can reach it on the alternate path url...

edit 2 see screenshot in better resolution at: http://www.tiikoni.com/tis/view/?id=5c2a5fe screenshot: On the left screen, you can see the view settings and on the right screen, in the April 2014 & May 2014 sections, you can clearly see that the filter Content: Title (contains Brunch) doesn't get recognized

  • 1
    Just to verify: your're using the regular filter (not exposed) in the page display (not block, attachment..), am I right? Is the AJAX option turned on or off? – rreiss Apr 17 '14 at 5:00
  • Might you try using Contextual filters. – J Sinha Apr 17 '14 at 5:31
  • Do you have caching enabled in view settings or any other caching like APC, Memcache, Varnish etc? – Елин Й. Apr 17 '14 at 7:56
  • @Rotem Yes, regular, exposed checkbox is not checked. Use AJAX: is set to No. – stdcerr Apr 17 '14 at 12:21
  • @JSinha Caching under ADVANCED is set to None – stdcerr Apr 17 '14 at 12:24
0

The Filter criteria didn't get applied properly because both Displays had the same name. It is required that both View displays have different names to be able to apply filters to only one Display.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.