0

I tried following the directions drupal provides for upgrading a site, but something went wrong. Now I can't log into the admin page (and the site is in maintenance mode). I'm getting the following errors:

Notice: Undefined index: bluemarine in drupal_theme_initialize() (line 100 of /home1/osuskite/public_html/includes/theme.inc).
Notice: Trying to get property of non-object in _drupal_theme_initialize() (line 145 of /home1/osuskite/public_html/includes/theme.inc).
Notice: Trying to get property of non-object in _theme_load_registry() (line 283 of /home1/osuskite/public_html/includes/theme.inc).
Notice: Undefined index: bluemarine in theme_get_setting() (line 1166 of /home1/osuskite/public_html/includes/theme.inc).
Notice: Undefined index: bluemarine in template_preprocess_maintenance_page() (line 2433 of /home1/osuskite/public_html/includes/theme.inc).
Notice: Trying to get property of non-object in template_preprocess_maintenance_page() (line 2433 of /home1/osuskite/public_html/includes/theme.inc).
Warning: array_keys() [function.array-keys]: The first argument should be an array in template_preprocess_maintenance_page() (line 2436 of /home1/osuskite/public_html/includes/theme.inc).
Warning: Invalid argument supplied for foreach() in template_preprocess_maintenance_page() (line 2436 of /home1/osuskite/public_html/includes/theme.inc).

And then a second error:

Warning: Cannot modify header information - headers already sent by (output started at /home1/osuskite/public_html/includes/common.inc:2567) in drupal_send_headers() (line 1018 of /home1/osuskite/public_html/includes/bootstrap.inc).
PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'osuskite_drupal.cache_token' doesn't exist: DELETE FROM {cache_token} WHERE (expire <> :db_condition_placeholder_0) AND (expire < :db_condition_placeholder_1) ; Array ( [:db_condition_placeholder_0] => 0 [:db_condition_placeholder_1] => 1316109148 ) in cache_clear_all() (line 169 of /home1/osuskite/public_html/includes/cache.inc).
Notice: Undefined index: bluemarine in template_preprocess_maintenance_page() (line 2433 of /home1/osuskite/public_html/includes/theme.inc).
Notice: Trying to get property of non-object in template_preprocess_maintenance_page() (line 2433 of /home1/osuskite/public_html/includes/theme.inc).
Warning: array_keys() [function.array-keys]: The first argument should be an array in template_preprocess_maintenance_page() (line 2436 of /home1/osuskite/public_html/includes/theme.inc).
Warning: Invalid argument supplied for foreach() in template_preprocess_maintenance_page() (line 2436 of /home1/osuskite/public_html/includes/theme.inc).

From what I could surmise, there error is being caused by Acquia Marina. I have downloaded the latest version and put it into the themes directory, but the error didn't change.

Any help would be appreciated. Googling this issue only pointed me to hundreds of other sites with the error instead of a solution.

EDIT: Truncating the SQL caches did nothing.

2

Switch to a stock D7 theme - clearing the cache is not enough if there's a bug in your theme as the buggy code is still going to reload.

  • Either use drush (highly recommended) to change your default theme to another, or...
  • Use the techniques mentioned here (should apply to D7): http://drupal.org/node/200774 or...
  • Rollback to your D6 code/database, disable the borked theme, and then retry the upgrade.
1
  • Thank you so much for pointing out drush. I had to disable a few themes and modules, but I have access to my site now!
    – MikeKusold
    Sep 16 '11 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.