0

I have a view that shows some custom user fields as block on the users profile page. The permission of that view is set to »Access: Permission | View published content«. That means the view should be visible for any visitor. This works fine on any user profile but not on the profile of the administrator with the uid 1. On his profile page the view is empty. Is this a bug or a wanted behaviour? How to solve this?

UPDATE: I tried to solve this by changing the view's access permissions but even if I set them to »none« or »Roles | All« it does not work.

  • Perhaps this is because the permission (can) "View Published Content" does not make sense for an admin ... i.e. if you could disable it, you might get locked out of your site... – iain maitland Jun 17 '14 at 20:15
  • @gl2748 It does not work with any permissions. I updated the question. – user5950 Jun 17 '14 at 22:08
0

Try using "Access: Role" rather than "Access: Permission" and select all user roles (that you'd like to be able to see the view ...

  • No, this does not work. Sorry didn't mention that I did try that before… – user5950 Jun 17 '14 at 22:07
  • What is inside your view? – iain maitland Jun 17 '14 at 23:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.