0

I have created a view by the name of news and there is an option under page setting by the name of access.

I have selected view any news content for the access option, then I have faced a problem. The problem is when I give any kind of view permission for news view, I cant access except give the permission of view any news content.

What do I have to do to give a permission of 'view own news content' so every person can see his/her news content?

1

Create a relationship between the current content type, and users.

Select Content: Author and click on Add and configure relationships. Leave the settings as they are and click on Apply (all displays).

Filtering the view

Now you need to filter the view to display only content authored by the current user.

Use the filter "User: Current".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.