0

I can't get rid of this display bug.

I set a Help text for all my content-type's fields to guide my users in the node add/edit forms.

However, these text blocks seem to show up randomly in the form page. Illustration:

enter image description here

Yes, I can assure you that all the fields have a help text set up in the administration interface.

There are no similarities between the field's types. There are text, select lists, taxonomy term reference, etc...

I tried without the field groups (we never know). But no luck.

My config is Drupal 7.32 and my theme is based on Bootstrap 7.x-3.0.

Any idea?

EDIT:

No, they not appear in HTML source at all.

Here is a part of the source code showing one field without help text and one field with help text:

<div id="edit-field-function-title" class="field-type-text field-name-field-function-title field-widget-text-textfield form-group col-xs-6 form-wrapper form-group">
  <div id="field-function-title-add-more-wrapper">
    <div class="form-type-textfield form-item-field-function-title-und-0-value form-item form-group">
      <label for="edit-field-function-title-und-0-value">
      <input id="edit-field-function-title-und-0-value" class="text-full form-control form-text required" type="text" maxlength="255" size="60" value="" name="field_function_title[und][0][value]">
    </div>
  </div>
</div>
<div id="edit-field-organisme" class="field-type-taxonomy-term-reference field-name-field-organisme field-widget-autocomplete-deluxe-taxonomy form-group col-xs-6 form-wrapper form-group">
  <div class="form-type-autocomplete-deluxe form-item-field-organisme-und form-item form-group">
    <label for="edit-field-organisme-und">
    <div class="autocomplete-deluxe-container">
      <input id="autocomplete-deluxe-input--2" class="autocomplete-deluxe-form form-control form-text jquery-once-2-processed ui-autocomplete-input autocomplete-deluxe-form-single" type="text" size="60" value="" name="field_organisme[und][textfield]" autocomplete="off" role="textbox" aria-autocomplete="list" aria-haspopup="true">
      <div class="autocomplete-deluxe-throbber autocomplete-deluxe-closed"> </div>
      <p class="help-block">Ce champ est destiné à l'organisme, structure, société, entreprise, cause, fédération, etc. à laquelle la personne physique ou l'entité appartient et pour laquelle elle est référencée dans Grape.</p>
    </div>
  </div>
</div>
  • If you view source is the markup for the help text there (and being hidden via css possibly), or is it missing from the markup altogether? – Clive Oct 31 '14 at 10:33
  • They not appear in the markup at all. Sorry to forget to mention that of course!!! @Clive – Djouuuuh Oct 31 '14 at 10:34
  • 2
    I don't know the Bootstrap theme too well but the responsible party is probably bootstrap_form_element() in theme/system/form-element.func.php, round about line 70 – Clive Oct 31 '14 at 10:44
  • Indeed, if I comment some lines in this function, all my help texts appear. That's embarrassing because I don't see yet how I am going to fix that... Well, thank you very much for pointing me the source of this issue! – Djouuuuh Oct 31 '14 at 10:51
0

The solution was very simple actually. It was a config in theme administration that set all text blocks having less than 200 chars as tooltips and not as help blocks. All I had to do is disabling that config:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.