0

Drupal gives me the following message:

There is a security update available for your version of Drupal. To ensure the security of your server, you should update immediately! See the available updates page for more information and to install your missing updates.

But when I click on available updates, it says:

Manual updates required

Updates of Drupal core are not supported at this time.

So what should I do?

2

You can update modules directly through the admin panel, but Drupal cannot update itself (at least not yet). So you will have to do that upgrade through the filesystem by uploading the new Drupal core files in place of the old ones, or (preferably) the command line with Drush.

Here is an instructional page:

You can also find guidance in the UPGRADE.txt file in the Drupal core package.

If you are familiar with the command line, you can use Drush to do updates which makes it very quick and easy. If you are not familiar with Drush, here is a beginner's guide.

  • So when I update Drupal,what will happen to the modules that I have installed? – user3530082 Nov 5 '14 at 4:45
  • Leave them in the sites folder and they should be fine. (See the full description above for more detailed info) – Laryn - CEDC.org Nov 5 '14 at 5:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.