1

For some reason Drupal is parsing my landing pages address with both alias and clean url. Meaning that the landing page for new users becomes /dashboard&destination=node/30 instead of ?q=dashboard or ?q=node/30.

I have tried disabling clean url by unchecking use clean urls (?q=admin/config/search/clean-urls) and clearing the cache, but it still uses them (e.g problem continues). So I was hoping somebody might enlighten me how to force Drupal not to use clean url:s?

Thanks

0

1 Answer 1

0

Try to run drush command : drush vset clean_url 0 --yes

or

Include a line in settings.php : $conf['clean_url'] = 0;

Updated :

Check this LINK. There are many ways to disable the clean url.

3
  • Added the line to settings.php but it still keeps parsing the url in the same way
    – newbie
    Dec 15, 2014 at 11:55
  • check the updated answer @newbie
    – Nishant
    Dec 15, 2014 at 13:11
  • I am accepting yous answer, since upon diving deeper to the problem it would seem that the real issue is with Drupal login and its redirection (it somehow still gets the clean url values, but is not neccecearly a clean url problem)
    – newbie
    Dec 15, 2014 at 13:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.