0

I want to use tokens in my content but it seems like it doesn't let me. I've found an article about using the Token Filter module but I have not been able to configure it so that it would print. In the README.TXT it says,

Go to /admin/settings/filters and enable the token_filter for any of your existing filter type or if you wish, create a new one.

but my problem is, when I go to http://127.0.0.1/drupal-7.34/#overlay=%3Fq%3Dadmin%252Fsettings%252Ffilters (on my installation, I just get to see enter image description here and I'm not sure how I can "enable the token_filter for any of your existing filter type" - may anyone help me?

Thank you!

0

Actually in order for this to work you need the token filter module:

https://www.drupal.org/project/token_filter

Otherwise there is no option in text format config.

|improve this answer|||||
0

README file of D7 version of module seems to be outdated, couple of things to ensure here:

  1. Token filter module is enabled.
  2. Navigate to text format section: Home » Administration » Configuration » Content authoring (URL: <DOMAIN-URL>/admin/config/content/formats)
  3. Either edit any of the existing text formats or else create new text format and select the option: Replace tokens
  4. Now verify Filter processing order present just below this options, to make sure Replace tokens doesn't overridden by some other option.
  5. Check permission for this updated/created text format (required user roles have permission to access this text format)
  6. Try creating content, however ensure the text format is one update/create above.
|improve this answer|||||
-1

On Drupal 7, you set the text formats at admin/config/content/formats; so, on your site it should be http://127.0.0.1/drupal-7.34/admin/config/content/formats. Click on configure for the format you want to change.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.