1

I have 1 node of the content type "tourism" and 2 nodes of the content type "tourism news". All 3 nodes belong to the same author (uid 33).

The "tourism" content type has a dynamic display suite field "news" which includes the content pane of a view. This view should displays all "tourism news"-nodes depending on the uid of the requestet "tourism"-node.

View

Context

Content Pane

When I enter the uid 33 in the preview, the view works as it should:

Preview

But when I open the "tourism" node - depending on my configuration - all news or no news are displayed. How do I have to configure the view and the dynamic field to pass the uid to the view?

Thanks in advance.

0

You are incorrectly setting the 'Argument input' for the Content Pane. It needs to be Node -> Author

Then you need to make sure that you pass the correct argument to it from the Dynamic Field in Display settings for the node. Make sure that you select 'View Panes' and not 'Views'. When you do it will show you the View pane view that you created, and when you select that it will present you with a select list titled: 'Content: Author uid', from which you select the only choice available, which is 'Node being viewed'.

I also do not think that setting the 'When the filter value is not available' in views will have any effect at all. This content pane display is only used for the dynamic field which will always get an argument.

  • Thanks for your reply. I've set up everything as described and it works perfectly on one content type. On a different content type I can't get it to work. What worked was: Argument Input -> Input on pane config and setting [node:author] as value in die dynamic field. Each configuration works only on one content type and I don't understand why ... – KieBar Feb 25 '15 at 11:23
  • Make sure your dyunamic field is created for node and for all the bundles you want to use it on. Then check your view filter by content type. Probably one of those two things. – J. Reynolds Feb 25 '15 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.